Section:

Depends : alsa-lib, at-spi2-core, ca-certs, cairo, cups, curl, desktop-file-utils, expat, flac, gtk-3, harfbuzz, hicolor-icon-theme, icu, libdrm, libpng, libxcb, mesa, nss, opus, perl-file-basedir, snappy, speech-dispatcher, wget, x11-lib, xdg-utils

Replaces : google-chrome<=54.0.2840.100

Breaks : google-chrome<=54.0.2840.100

Links: Changelog, QA Page, Report issues

Available versions

Version 126.0.6478.182 126.0.6478.126126.0.6478.114126.0.6478.61126.0.6478.55125.0.6422.141125.0.6422.60124.0.6367.118124.0.6367.91124.0.6367.60123.0.6312.86123.0.6312.58-1123.0.6312.58122.0.6261.57120.0.6099.224
amd64 109 MiB 109 MiB 109 MiB 109 MiB 109 MiB 109 MiB 109 MiB 108 MiB 108 MiB 108 MiB 108 MiB 108 MiB 108 MiB 107 MiB 106 MiB